Loka á facebook og myspace?

Ef að þú ert með Cisco IOS router, þá geturu á nokkuð einfaldan hátt lokað á ákveðnar síður.
Tildæmis síður eins og facebook, myspace, youtube eða aðrar síður sem að þú vilt ekki að starfsfólk eða heimilisfólk sé að eyða tímanum sínum á.
Það má jafnvel tengja þetta við tíma. Þannig að ákveðnar síður séu bara opnar í kringum hádegið, en annars lokaðar.
Á heimilisrouter mætti útfæra þetta þannig að lokað væri á þær síður sem barnið eða unglingurinn er mest á yfir nóttina, til að mögulega minnka netnotkun yfir nóttina.
Þeir innbyggðu fítusar sem Cisco routerar eru með til að gera þetta kleift koma ekki í staðinn fyrir professional lausnir eins og websense eða ironport.
En ef þú vilt vita hvernig þú getur gert svona með cisco router, lestu þá áfram.


Tólin sem við notum til að gera þetta mögulegt eru policy-map, class-map og access-listar.
Hugmyndin gengur út á að “merkja” ákveðna umferð (QoS), og stöðva svo alla umferð með þessari merkingu.

Dæmi 1.
Tilgangur: loka á facebook og youtube.
Lausn:

Í config-mode er eftirfarandi gert:

class-map match-any class-http-lokad
match protocol http host “*youtube.com”
match protocol http host “*facebook.com”
match protocol http host “*fbcdn.net”

og

policy-map pol-http-lokad
class class-http-lokad
set dscp 1

og

access-list 120 deny ip any any dscp 1
access-list 120 permit ip any any

og svo

interface Dialer1 ( eða “ytra” interface-ið á routernum)
ip access-group 120 out

og svo

interface Vlan1 (eða “innra” interface á routernum)
service-policy input pol-http-lokad

 

Nú ætti að vera aðeins erfiðara að nota facebook og youtube.

Í “class-map” er hægt að nota “match protocol http url” í stað “match protocol http host”, og þá er hægt að grípa ákveðin key-words.
Sem dæmi:
match protocol http url “*facebook*”
myndi loka á
http://www.simnet.is/~notandi/facebook/index.html
afþví að “facebook” kemur fyrir í slóðinni.

Til að skoða hvort að einhverjir pakkar séu merktir er hægt að nota eftirfarandi skipun:
show policy-map interface vlan1
Það er auðvitað hægt að gera þetta í Cisco ASA eldveggjum líka, þó það sé ekki farið yfir það config hér.

3 thoughts on “Loka á facebook og myspace?

  1. Væri ekki einfaldara að droppa þessu beint úr policy mappinu?
    Það ætti að spara smá processing líka.

    policy-map pol-http-lokad
    class class-http-lokad
    drop

  2. hvernig tengiru þetta við tíma ?
    t.d. einsog þú talar umm þarna að loka á ákveðnar síður eftir miðnætti eða bara opið í hádeiginu ect ?

Leave a Comment